D-Link DES-7200 Refrigerator User Manual


  Open as PDF
of 1968
 
DES-7200 Configuration Guide Chapter 2 Configuring BGP IP VPN
2-108
ASBR1:
# Configure the loopback interface.
DES-7200# configure terminal
DES-7200(config)# interface loopback 0
DES-7200(config-if-Loopback 0)# ip address 3.3.3.3 255.255.255.255
# Configure ACL rules and route map rules to assign labels to or set labels only for routes that
match the rules.
DES-7200# configure terminal
DES-7200(config)# ip access-list extended 101
DES-7200(config-ext-nacl)# permit ip host 1.1.1.1 any
uijie(config-ext-nacl)# exit
DES-7200(config)# ip access-list extended 102
DES-7200(config-ext-nacl)# permit ip host 5.5.5.5 any
DES-7200(config-ext-nacl)# exit
DES-7200(config)# route-map set-mpls
DES-7200(config-route-map)# match ip address 101
DES-7200(config-route-map)# set mpls-label
DES-7200(config-route-map)# exit
DES-7200(config)# route-map external-pe-route
DES-7200(config-route-map)# match ip address 102
DES-7200(config-route-map)# end
# Set up an EBGP session with ASBR2 and configure route map rules to assign labels to PE
routes that match the rules (the route map rules are optional and allow BGP to assign labels to
only certain routes), and configure static routes to PEs in the local AS.
DES-7200# configure terminal
DES-7200(config)# router bgp 1
DES-7200(config-router)# neighbor 30.30.30.2 remote-as 2
DES-7200(config-router)# address-family ipv4
DES-7200(config-router-af)# neighbor 30.30.30.2 send-label
DES-7200(config-router-af)# neighbor 30.30.30.2 route-map set-mpls out
DES-7200(config-router-af)# network 1.1.1.1 mask 255.255.255.255
DES-7200(config-router-af)# end
# Configure MPLS to assign label to certain BGP routes through ACL rules (The ACL rules are
optional and allow you to reduce the number of unnecessary routes).
DES-7200# configure terminal
DES-7200(config)# mpls ip