D-Link DES-7200 Refrigerator User Manual


  Open as PDF
of 1968
 
DES-7200 Configuration Guide Chapter 2 Configuring BGP IP VPN
2-131
The configuration steps are the same as Scenario I. The difference is that routes are exchanged
between PE and CE. Only PE-CE route exchanging configurations will be shown below. For
other configurations, please refer to the section of "Configuring Basic BGP/MPLS VPN
Functions" for the example of "Second Carrier provides Internet service based on IP core".
# Configure route exchanging between PE and CE
## Configure on PE (taking PE1 as the example)
DES-7200(config)# router bgp 65001
DES-7200(config-router)# address-family ipv4 vrf vpn1
DES-7200(config-router-af)# neighbor 172.1.1.2 remote-as 65010
DES-7200(config-router-af)# neighbor 172.1.1.2 as-override
DES-7200(config-router-af)# exit
DES-7200(config-router)# exit
## Then, configure on CE (taking CE1 as the example)
DES-7200(config)# router bgp 65010
DES-7200(config-router)# neighbor 172.1.1.2 remote-as 65001
DES-7200(config-router)# redistribute ospf 1
DES-7200(config-router)# exit
DES-7200(config)# router ospf 1
DES-7200(config-router)# redistribute bgp 65010 subnets
DES-7200(config-router)# exit
Enable CSC function
# Enable CSC on PE: Here we will take PE1 as the example. The configurations of PE2 are the
same.
DES-7200(config)# interface gigabitEthernet 1/1
# In case of a switch, configure the interface to RoutedPort interface (not applicable to a
router)
DES-7200(config-if)# no switchport
# In case of a router, enable fast forwarding on the interface (not applicable to a switch)
DES-7200(config-if)# ip ref
DES-7200(config-if)# ip vrf forwarding vpn1
DES-7200(config-if)# ip address 172.1.1.1 255.255.255.0
DES-7200(config-if)# no shutdown
DES-7200(config-if)# exit
DES-7200(config)# router bgp 65001
DES-7200(config-router)# address-family ipv4 vrf vpn1
DES-7200(config-router-af)# neighbor 172.1.1.2 send-label