D-Link DES-7200 Refrigerator User Manual


  Open as PDF
of 1968
 
DES-7200 Configuration Guide Chapter 2 Configuring BGP IP VPN
2-119
# Configure ACL rules and route map rules.
DES-7200# configure terminal
DES-7200(config)# ip access-list extended 101
DES-7200(config-ext-nacl)# permit ip host 1.1.1.1 any
DES-7200(config-ext-nacl)# exit
DES-7200(config)# ip access-list extended 102
DES-7200(config-ext-nacl)# permit ip host 5.5.5.5 any
DES-7200(config-ext-nacl)# permit ip host 9.9.9.9 any
DES-7200(config-ext-nacl)# exit
DES-7200(config)# route-map internal-mpls-route permit 10
DES-7200(config-route-map)# match ip address 101
DES-7200(config-route-map)# set mpls-label
DES-7200(config-route-map)# exit
DES-7200(config)# route-map external-mpls-route permit 10
DES-7200(config-route-map)# match ip address 102
DES-7200(config-route-map)# set mpls-label
DES-7200(config-route-map)# end
# Set up an EBGP session with the ASBR, enable label switching of IPv4 routes, and configure
route map rules to assign labels to PE routes that match the rules (the route map rules are
optional and allow the BGP to assign labels to only certain routes). Set up an IBGP session with
the RR, enable label switching of IPv4 routes, and configure route map rules to assign labels to
inter-PE routes that match the rules. Configure static routes to the PEs in the local AS.
DES-7200# configure terminal
DES-7200(config)# router bgp 1
DES-7200(config-router)# neighbor 30.30.30.2 remote-as 2
DES-7200(config-router)# neighbor 2.2.2.2 remote-as 1
DES-7200(config-router)# neighbor 2.2.2.2 update-source loopback 0
DES-7200(config-router)# address-family ipv4
DES-7200(config-router-af)# neighbor 30.30.30.2 send-label
DES-7200(config-router-af)# neighbor 30.30.30.2 route-map internal-mpls-route out
DES-7200(config-router-af)# neighbor 2.2.2.2 send-label
DES-7200(config-router-af)# neighbor 2.2.2.2 route-map external-mpls-route out
DES-7200(config-router-af)# network 1.1.1.1 mask 255.255.255.255
DES-7200(config-router-af)# end
# Configure MPLS signaling and enable MPLS on an interface.
DES-7200# configure terminal
DES-7200(config)# mpls ip
DES-7200(config)# mpls router ldp