D-Link DES-7200 Refrigerator User Manual


  Open as PDF
of 1968
 
DES-7200 Configuration Guide Chapter 2 Configuring BGP IP VPN
2-164
# Configure VRF
Create two VRFs of "VPN1" and "VPN2" to represent different services, and associate VRF with
the corresponding interface.
DES-7200# configure terminal
DES-7200(config)# ip vrf VPN1
DES-7200(config-vrf)# rd 1:100
DES-7200(config-vrf)# route-target both 1:100
DES-7200(config-vrf)# end
DES-7200# configure terminal
DES-7200(config)# ip vrf VPN2
DES-7200(config-vrf)# rd 1:200
DES-7200(config-vrf)# route-target both 1:200
DES-7200(config-vrf)# end
# Associate the CE-connecting interface with VRF
DES-7200(config)# VLAN 10
DES-7200(config)# interface vlan 10
# VLAN is the configuration command used on switch products, and is not applicable to routers
(except for the switching card interface). Routers can use the subinterface to bind VRF.
DES-7200(config-if-vlan 10)# ip vrf forwarding VPN1
DES-7200(config-if-vlan 10)# ip address 192.168.10.1 255.255.255.0
DES-7200(config)# VLAN 20
DES-7200(config)# interface vlan 20
# VLAN is the configuration command used on switch products, and is not applicable to routers
(except for the switching card interface). Routers can use the sub-interface to bind VRF.
DES-7200(config-if-vlan 20)# ip vrf forwarding VPN1
DES-7200(config-if-vlan 20)# ip address 192.168.20.1 255.255.255.0
# Configure BGP protocol to establish MP-IBGP session with PE2
DES-7200# configure terminal
DES-7200(config)# router bgp 1
DES-7200(config-router)# neighbor 172.168.0.2 remote-as 1
DES-7200(config-router)# neighbor 172.168.0.2 update-source loopback 0
DES-7200(config-router)# address-family vpnv4