DES-7200 Configuration Guide Chapter 2 Configuring BGP IP VPN
2-116
# Set up an MP-IBGP session with the RR and enable label exchanging of IPv4 routes.
DES-7200# configure terminal
DES-7200(config)# router bgp 1
DES-7200(config-router)# neighbor 2.2.2.2 remote-as 1
DES-7200(config-router)# neighbor 2.2.2.2 update-source loopback 0
DES-7200(config-router)# address-family vpnv4 unicast
DES-7200(config-router-af)# neighbor 2.2.2.2 activate
DES-7200(config-router-af)# exit
DES-7200(config-router)# address-family ipv4
DES-7200(config-router-af)# neighbor 2.2.2.2 activate
DES-7200(config-router-af)# neighbor 2.2.2.2 send-label
DES-7200(config-router-af)# end
# Configure CE neighbors through EBGP.
Refer to the configuration procedure in Running BGP Between a PE and CE to Transmit VPN
Routes and the related configurations in Intranet Configuration Examples.
The configurations of PE1-AS2 and PE1-AS3 are similar to that of PE1-AS1.
RR-AS1
# Configure the loopback interface.
DES-7200# configure terminal
DES-7200(config)# interface loopback 0
DES-7200(config-if-Loopback 0)# ip address 2.2.2.2 255.255.255.255
# Set up an MP-IBGP session with the PE, specify the PE as the RR client, and enable label
exchanging of IPv4 routes.
DES-7200# configure terminal
DES-7200(config)# router bgp 1
DES-7200(config-router)# neighbor 1.1.1.1 remote-as 1
DES-7200(config-router)# neighbor 1.1.1.1 update-source loopback 0
DES-7200(config-router)# address-family vpnv4 unicast
DES-7200(config-router-af)# neighbor 1.1.1.1 activate
DES-7200(config-router-af)# neighbor 1.1.1.1 route-reflector-client
DES-7200(config-router-af)# exit
DES-7200(config-router)# address-family ipv4